mdi

Compiling

To compile the example:

  • Launch EiffelStudio.
  • Click Add project
  • Browse to $ISE_EIFFEL\examples\wel\mdi\.
  • Choose mdi.ecf
  • Choose the location where the project will be compiled, by default the same directory containing the configuration file.
  • Click OK.

Running

After launching the program, a window will be displayed as illustrated above. Selecting "New" from the "File" menu will create a new child window, while selecting "Close" will close the currently selected child window. The options available on the "Window" menu allow positioning of the child windows. Selecting "Exit" from the "File" menu or closing the window manually will exit the program.

Under the Hood

MAIN_WINDOW inherits WEL_MDI_FRAME_WINDOW to provide the multiple document interface behavior while each child window is of type WEL_MDI_CHILD_WINDOW . When "Close" is selected from the "File" menu, the feature active_window from WEL_MDI_FRAME_WINDOW is used to select the window that must be closed. This sample contains the following classes:

  • APPLICATION_IDS
  • MAIN_WINDOW
  • MDI_DEMO

See Also:
Bmpview

e5f4b1d5-31a1-51a3-46ea-3cf70a4b40d7
cached: 03/24/2017 10:20:23.000 PM